رفتن به مطلب

ارسال نشدن ایمیل فعالسازی به کاربران


ارسال های توصیه شده

این تاپیک ادامه یک تاپیک دیگر بود که در آن فرموده بودند که به پشتیبانی هاستتون تیکت بزنید. آخرین پاسخی که هاست به من داده این بوده:

 

با سلام خدمت شما


تا جایی که بررسی شد سرویس ایمیل و تابع Mail به صورت کامل بر روی اکانت و دامنه ی شما فعال میباشد
لطفاً برمایید از چه طریق و با چه آدرسی نسبت به ارسال ایمیل از انجمن به کابران خود اقدام میکنید؟

 

طبق فرموده یکی از دوستان این انجمن، من گفته بودم که phpmail را بررسی بفرمایند.آنها هم پاسخ بالا را دادند. من نمیدونم چه اطلاعاتی باید بهشون بدم.لطفا راهنمایی بفرمایید.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

وقتی شما از منوی Support و مسیر 

Diagnostics  >  Overview  >  Email Tester

اقدام به ارسال ایمیل تست برای خودتون میکنید ، هیچ ایمیلی ارسال نمیشه ؟! حتی پوشه Spam ؟

 

آیا بررسی کردید که تنظیمات ایمیل بر روی PhpMail تنظیم شده یا خیر؟

از مسیر زیر

System Settings  >  Global Settings  >  System  >  Email Set-up

و گزینه Mail delivery method

 

//

 

اگر گزینه های بالا انجام شده پس به هاستینگ اطلاعات بیشتری بدهید و بفرمایید که تنظیمات اسکریپت IPB به درستی اعمال شده اما ایمیل ارسال نمیشود .

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بله تنظیمات بالا انجام شده است. ظاهرا مشکل از هاست نیست. ایمیل تست ارسال گردید.اما زمانی که کاربر عضو میشود ایمیلی برای وی ارسال نمیشود.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

آیا شما تنظیمات مربوط به New registration email validation در مسیر

System Settings  >  Global Settings  >  System  >  Security and Privacy

رو بر روی User Email Validation قرار دادید ؟ 

 

 

 و گزینه Community outgoing email address رو مقدار دهی کردید ؟

 

اگر موارد بالا صحیح است طبق آموزش زیر عمل کنید 

http://invisionmodding.com/tutorials/article/556-email-debugging/
لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • 2 هفته بعد...

 

آیا شما تنظیمات مربوط به New registration email validation در مسیر

System Settings  >  Global Settings  >  System  >  Security and Privacy

رو بر روی User Email Validation قرار دادید ؟ 

 

 

 و گزینه Community outgoing email address رو مقدار دهی کردید ؟

 

اگر موارد بالا صحیح است طبق آموزش زیر عمل کنید 

http://invisionmodding.com/tutorials/article/556-email-debugging/

 

من همچنان نمیتونم مشکلم رو حل کنم. کلا هیچ ایمیلی ارسال نمیشه.حتی ایمیل تست خود آی پی بی هم ارسال نمیشه.(اول اون قسمت درست بود اما الان همون ایمیل تستی هم خراب شده.) بعد از کلی تیکت بازی با هاست ، هاست گفت که برات گزارش خطای پی اچ پی رو روشن میکنم. 

الان سوالم اینه:

- من چجوری باید توی ای پی بی گزارش خطا رو نمایش بدم؟

- کسی راه حل دیگه ای داره برای حل مشکلم؟ من اون لینکی که آقای قربانپور رو داده بود برای دیباگ گرفتن رو هم خوندم و اعمال کردم و اون دیباگ ها رو هم روی هاستم ذخیره کردم.(به دردم نخورد و چیزی از توش درنیومد.فقط ایمیل هایی که توسط آی پی بی ساخته میشه رو ذخیره میکنه)

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

با سلام :)

شما اسکریپت دیگه ای مثل وردپرس نصب کنید از اونجا تست کنید اصلا می تونید ایمیل ارسال کنید یا خیر. اگر از اونجا هم نشد (که مطمئنا نخواهد شد) این یعنی اینکه پشتیبانی شما اگر گزارش خطا PHP رو هم روشن کنه به درد نمی خوره. تنظیمات ایمیل سرور مشکل داره. مشکل از اسکریپت نیست مشکل از Config سروره! اونا باید به فکر رفع مشکل باشن نه شما.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

با سلام :)

شما اسکریپت دیگه ای مثل وردپرس نصب کنید از اونجا تست کنید اصلا می تونید ایمیل ارسال کنید یا خیر. اگر از اونجا هم نشد (که مطمئنا نخواهد شد) این یعنی اینکه پشتیبانی شما اگر گزارش خطا PHP رو هم روشن کنه به درد نمی خوره. تنظیمات ایمیل سرور مشکل داره. مشکل از اسکریپت نیست مشکل از Config سروره! اونا باید به فکر رفع مشکل باشن نه شما.

سلام.

من یه جوملا خام نصب کردم و طبق حرف شما ایمیلی پس از ثبت نام در جوملا ، ارسال نمی شد و ارور میداد که تابع ایمیل را نمی توان فراخوانی کرد. و بعد از کلی تیکت بازی با سرور، مشکل جوملا (که تو روت IPB نصب کرده بودم) حل شد. اما مشکل IPB به قوت خودش باقیه . آخرین تیکتی که جوابمو دادند این بوده:

 

 

با سلام خدمت شما

تابع میل و همچنین تابع

fsockopen

برای اتصال

SMTP

فعال شد.

لطفا بررسی نمایید و در صورت وجود مشکل اطلاع دهید.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi
تابع میل و همچنین تابع fsockopen برای اتصال SMTP فعال شد.

!!!!!!!

شما توی Error Log سرورتون رو نگاه کنید ببینید چه خطایی هایی مرتبط با میل می بینید. این طوری که شما مطرح کردید فکر نمی کنم کمکی از دست ما بر بیاد!! تا قبل از این گفتن که مشکل از IPB هست بعد که جوملا نصب کردید که فوق العاده معروف هست متوجه مشکل شدن، من فکر نمی کنم شما به نتیجه ای با پشتیبانی برسید!

لینک ارسال
به اشتراک گذاری در سایت های دیگر

سلام.

آقا وحید من از پاسخ های شما ممنونم و میدونم این تاپیک یکم داره طولانی میشه.

سرور هم انصافا خیلی خوب و با تمام قدرتشون و خیلی پرسرعت داره با من همکاری میکنه.

من جوملا نصب کردم و ابتدا مشکل داشت و ایمیل ارسال نمیشد اما خب اون رو هم درست کردند.یعنی تنظیمات سرور را به حدی تغییر دادند که در جوملا هم به روش smtp وهم php_mail الان ایمیل عضویت ارسال میشه.وجوملا رو هم من  روت IPB نصب کردم.

در هر صورت هنوز هم مشکل عدم ارسال ایمیل از طریق آی پی بی برای من وجود داره.

الان میخام یه پیشنهاد بدم میشه بفرمایید شدنی هست؟

من میخام همه فایلهای هسته IPB رو جایگزین کنم.آیا برای این کار راه منطقی وجود داره؟ یا اگه IPB رو به ورژن 3.4.7 ارتقا بدم(الان 3.4.6ام) ارتقا بدم این اتفاق میفته؟(یعنی با این کار کلیه فایلهای هسته جدید جایگزین هسته قدیم میشه؟(من یه زمانی یکم این هسته رو شخصی سازی کردم میگم شاید از اون باشه،البته برای پوسته بود بیشتر)

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi
آقا وحید من از پاسخ های شما ممنونم و میدونم این تاپیک یکم داره طولانی میشه.

خواهش می کنم

 

 

سرور هم انصافا خیلی خوب و با تمام قدرتشون و خیلی پرسرعت داره با من همکاری میکنه.

مساله اینجاست سرور شما به احتمال خیلی زیاد داره یا از Postfix یا Exim یا dovecot برای مدیریت ایمیل ها استفاده می کنه. هر سه تای این برنامه ها به صورت پیش فرض طوری تنظیم شدن که از توابع استاندارد ارسال ایمیل پشتیبانی کنند. من توجه شما رو به این نکته جلب می کنم که شما اول گفتید :

من یه جوملا خام نصب کردم و طبق حرف شما ایمیلی پس از ثبت نام در جوملا ، ارسال نمی شد و ارور میداد که تابع ایمیل را نمی توان فراخوانی کرد.

خوب این یعنی اینکه تنظیمات سرور مشکل داشته !

 

 

من میخام همه فایلهای هسته IPB رو جایگزین کنم.آیا برای این کار راه منطقی وجود داره؟ یا اگه IPB رو به ورژن 3.4.7 ارتقا بدم(الان 3.4.6ام) ارتقا بدم این اتفاق میفته؟(یعنی با این کار کلیه فایلهای هسته جدید جایگزین هسته قدیم میشه؟(من یه زمانی یکم این هسته رو شخصی سازی کردم میگم شاید از اون باشه،البته برای پوسته بود بیشتر)

الان که شما از نسخه 3.4.6 استفاده می کنید اگر بروزرسانی های امنیتی رو مداوما روی انجمن تون اعمال نکرده باشید که خوب مسلما باید انتظار هک شدن انجمن تون رو داشته باشید اما اینکه هسته رو دستکاری کردید عملش جدا هست. شما به نسخه 3.4.7 بروزرسانی کنید امیدوارم مشکل حل بشه.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...

اطلاعات مهم

ما مجبور شدیم تا از کوکی ها و فناوری های مشابه برای اجرای این وب سایت استفاده کنیم تا بتوانیم تجربه بهتری در زمان استفاده از سایت برای شما ایجاد نماییم. سیاست حریم خصوصی.