رفتن به مطلب

خالی کردن کش آواتار


ارسال‌های توصیه شده

وقتی که آواتار عوض میکنم و کاربر ها عوض میکنن باید کش مرورگرم رو خالی کنم تا نشون داده بشه راهی هست برای حل این مورد

موضوع هم نمیدونم درست انتخاب کردم یا نه ببخشید این همه سوال می پرسم

  • پسند 1
لینک ارسال
به اشتراک گذاری در سایت های دیگر

اين يكی رو خدائی نميدونم ولی فكر كنم از طرف browser هستش كه بايد hard refresh كنيد همون ctrl+F5 -- شايد هم به خاطر استفاده از كد كشيه كه داخل httaccess گذاشتم باشه كه اين شكلی براتون نشون ميده، ولی خودم همچين مشكلی نداشتم...

  • پسند 2
لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

وقتی که آواتار عوض میکنم و کاربر ها عوض میکنن باید کش مرورگرم رو خالی کنم تا نشون داده بشه راهی هست برای حل این مورد

فقط برای شما این مشکل هست یا بقیه کابرا هم همین مشکل رو دارند ؟

موضوع هم نمیدونم درست انتخاب کردم یا نه ببخشید این همه سوال می پرسم

نه دوست من خواهش می کنم :wub:

  • پسند 2
لینک ارسال
به اشتراک گذاری در سایت های دیگر

براي بقيه كاربر ها هم همين طور هست توي همين انجمن هم اواتار عوض كردم ولي عوض نشد

كش طبق زمان خاصي خالي ميشه آيا ؟

كد كشيه كه داخل httaccess بله احتمالا چون تا قبل گذاشتن اون httaccess كه گفته بودين دانلود كنين و آژلود كنين براي امنيت همچين موردي نبود اگه درست يادم باشه

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi
كد كشيه كه داخل httaccess بله احتمالا چون تا قبل گذاشتن اون httaccess كه گفته بودين دانلود كنين و آژلود كنين براي امنيت همچين موردي نبود اگه درست يادم باشه

بله مشکل از htaccess هست. شما باید برای فایل های خاص تون مثل JPG مدت زمان کمتری رو بزارید یا می تونید حذفش کنید. راه موقتیش استفاده از CTRL + F5 هست.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

کد های کش درون htaccess رو اینجا بزارید تا بگم.

موفق باشید

لینک ارسال
به اشتراک گذاری در سایت های دیگر

من همون فایلی که دوست عزیزمون گذاشتن توی قسمت امنیت رو وارد کردم

<FilesMatch ".(gif|ico|jpg|jpeg|png|flv|swf|pdf|mp3|mp4|xml|txt|js|css)$">
Header set Cache-Control "max-age=691200"

فکر میکنم این باشه :wub:

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

اون کد رو حذف کنید به جای اون این کد ها رو بزارید و مدت زمان رو تعیین کنید. این تنها راهی هست که می شه اثر این کار رو کم کرد :


<files *.jpg>
 Header set Expires "access plus 6 hours"
</files>

<files *.png>
 Header set Expires "access plus 12 hours"
</files>

<files *.ico>
 Header set Expires "access plus 1 years"
</files>

<files *.gif>
 Header set Expires "access plus 3 days"
</files>

<files *.js>
 Header set Expires "access plus 7 days"
</files>

<files *.css>
 Header set Expires "access plus 7 days"
</files>

می تونید مدت زمان رو بر اساس نوع فایل تعیین کنید.

موفق باشید

  • پسند 1
لینک ارسال
به اشتراک گذاری در سایت های دیگر

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
<FilesMatch ".(gif|ico|jpg|jpeg|png|flv|swf|pdf|mp3|mp4|xml|txt|js|css)$">
Header set Cache-Control "max-age=691200"
</FilesMatch>
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE text/plain text/html text/xml text/css
AddOutputFilterByType DEFLATE application/javascript application/x-javascript
AddOutputFilterByType DEFLATE application/xml application/xhtml+xml application/rss+xml
</IfModule>
# Protect the conf_global.php file
<files conf_global.php>
ErrorDocument 403 http://www.iranlearn.org/403.html
Order deny,allow
deny from all
</files>
# Protect the initdata.php file
<files initdata.php>
ErrorDocument 403 http://www.iranlearn.org/403.html
Order deny,allow
deny from all
</files>
<files .htaccess>
ErrorDocument 403 http://www.iranlearn.org/403.html
Order deny,allow
deny from all
</files>

کلش این بود من کلا پاک کردم htaccess همه تاپیک ها هم خراب شد

دوباره اولی رو ریختم میشه یه htaccessبدین من وارد کنم

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...