رفتن به مطلب

مشکل با MySQL 5.5.3


ارسال های توصیه شده

با سلام و احترام

فایل بررسی نیازمندی‌ها رو روی هاست اشتراکی نت‌افراز فعال کردم این ارور رو داد:

MySQL Requirements
You are not running a compatible version of MySQL. You need MySQL 5.5.3 or above. You should contact your hosting provider or system administrator to ask for an upgrade

بهشون تیکت زدم، این جواب رو دادن:

به اطلاع میرسانیم با توجه به اینکه دیگر php از این پشتیبانی نمی کند و این نسخه مشکل امنیتی جدی دارد امکان ارائه آن توسط نت افراز وجود ندارد.

 

آیا این مطلب درسته؟ و آیا این امر برای امنیت سایت آسیب ایجاد خواهد کرد؟

اگر توضیحی بفرمایید ممنون میشم

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

با سلام

وقت بخیر

دقت بفرمایید که گفته شده حداقل 5.5.3! آخرین نسخه 8.0 هست و آخرین نسخه سری ۵ هم 5.7. شما به نسخه 5.7 یا 8.0 نیاز دارید. هاست شما کدوم نسخه رو داره؟

در ۱۴۰۰/۸/۳۰ در 14:15، محمدآبادی گفته است:

آیا این مطلب درسته؟ و آیا این امر برای امنیت سایت آسیب ایجاد خواهد کرد؟

بله چرا که نسخه ذکر شده خیلی قدیمی هست و صرفا جهت این ذکر شده که که نسخه شما استاندارد نیست.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

با سپاس از لطف شما

بخش دیگری از پشتیبانی، این توضیحات رو ارائه کردند و منتظر جواب نهایی ایشان هستم. 🤝

خطای ارسالی بیانگر نیاز به دسترسی به MySQL 5.5.3 را کرده است به نظر مشکلی در این خصوص وجود ندارد.
چرا که پایگاه داده MariaDB موجود بر روی سرویس های نت افراز صرفا نسخه اپن سورس مای اس کیو ال می باشد و نسخه های مختلف ماریا.دی.بی برخی نسخه های مای اس کیو ال را پشتیبانی نموده و در واقع پوشش میدهند، در حال حاضر نیز ورژن ماریا دی بی سرور میزبان هاست شما معادل MariaDB 10.4 بوده که این ورژن برابر با ورژنهای 5.6 و 5.7 مای اسکیو ال بوده و نتیجتا بر اساس پیغام ارسالی نمی بایست در این خصوص مشکلی باشد.

با درود

پاسخ هاستینگ این بود:

لازم به ذکر است در واقع ماریادی‌بی نسخه اپن سورس مای‌اس‌کیوال می‌باشد که توسط چند تن از تولید کننده‌های مای‌اس‌کیوال ایجاد شده است و دقیقا از سینتکس مای‌اس‌کیوال پشتیبانی می‌کند. بنابراین در این موارد احتمال این مسئله وجود دارد که مشکل در کدهای اعمال شدۀ شما برای ips4.php در چک‌کردن ورژن و عدم امکان شناسایی و تطابق‌دادن توسط کد باشد.

MariaDB-Compatibilty-Chart.jpg.90c3c91c12d9ebaf04ab0af613c492fd.jpg

لذا من هم اقدام به نصب کردم و بدون ارور نصب شد. ظاهراً کدهای فایل بررسی نیازمندی‌ها نیاز به آپدیت دارند.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi
در ۱۴۰۰/۸/۳۰ در 22:42، محمدآبادی گفته است:

لذا من هم اقدام به نصب کردم و بدون ارور نصب شد. ظاهراً کدهای فایل بررسی نیازمندی‌ها نیاز به آپدیت دارند.

خود IPS فعلا کاری برای این خطای اشتباه که MariaDB رو تشخیص نمیده فعلا نکرده. به محض بروزرسانی، حتما بروز می‌کنیم.

با تشکر از شما

لینک ارسال
به اشتراک گذاری در سایت های دیگر

به گفتگو بپیوندید

هم اکنون می توانید مطلب خود را ارسال نمایید و بعداً ثبت نام کنید. اگر حساب کاربری دارید، برای ارسال با حساب کاربری خود اکنون وارد شوید .
توجه: مطلب ارسالی شما پس از تایید مدیریت برای همه قابل رویت خواهد بود.

مهمان
ارسال پاسخ به این موضوع ...

×   شما در حال چسباندن محتوایی با قالب بندی هستید.   حذف قالب بندی

  تنها استفاده از 75 اموجی مجاز می باشد.

×   لینک شما به صورت اتوماتیک جای گذاری شد.   نمایش به صورت لینک

×   محتوای قبلی شما بازگردانی شد.   پاک کردن محتوای ویرایشگر

×   شما مستقیما نمی توانید تصویر خود را قرار دهید. یا آن را اینجا بارگذاری کنید یا از یک URL قرار دهید.

 اشتراک گذاری

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
  • اضافه کردن...

اطلاعات مهم

ما مجبور شدیم تا از کوکی ها و فناوری های مشابه برای اجرای این وب سایت استفاده کنیم تا بتوانیم تجربه بهتری در زمان استفاده از سایت برای شما ایجاد نماییم. سیاست حریم خصوصی.