رفتن به مطلب

عبارت index.php در انتهای آدرسها [حل شد]


ارسال های توصیه شده

  • بنیان گذار IPSFarsi

باسلام

تاپیک های زیر رو مطالعه کنید:

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

طبقتوضیحات پیش رفتم و موقع ذخیره کردن تنطیمات هشدار زیر رو با خطای 404 در برخی صفحه ها دریافت میکنم:

نقل قول

به نظر می رسد بازنویسی آدرس ها کار نمی کند.ممکن است این مشکل به دلیل عدم تنظیم سرور شما به طور صحیح باشد، البته اگر که سایت شما به صورت عمومی در دسترس نیست این خطا را می توانید نادیده بگیرید. برای اینکه بفهمید بازنویسی آدرس ها به طور صحیح کار می کند روی لینک هایی همانند نمایه کاربری کلیک نمایید، اگر با خطا 404 مواجه شدید، بازنویسی آدرس ها کار نمی کند. برای رفع این مشکل با پشتیبانی فضای میزبانی خود تماس بگیرید یا در IPSFarsi مشکل خود را مطرح نمایید.

در ضمن فایل رو هم دانلود و در روت انجمن اپلود کردم

لینک ارسال
به اشتراک گذاری در سایت های دیگر

خود ارور هم گفته ، اما به هر صورت ممکنه یه فایل دیگه htaccess وجود داشته باشه که برای اینکار از تنظیمات فایل منیجر هاست تیک نمایش فایل های پنهان رو بزنید و بعد آپلود کنید !

اما قبلش حتما گزینه مربوطه را فعال کرده و ذخیره کنید. فایل رو براتون پیوست کردم و کد درونش هم اینه. (فعال بودن این گزینه توصیه میشه)

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /404error.php [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

 

.htaccess

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • 2 هفته بعد...
  • Arash.Ranjbar عنوان را به عبارت index.php در انتهای آدرسها [حل شد] تغییر داد

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...

اطلاعات مهم

ما مجبور شدیم تا از کوکی ها و فناوری های مشابه برای اجرای این وب سایت استفاده کنیم تا بتوانیم تجربه بهتری در زمان استفاده از سایت برای شما ایجاد نماییم. سیاست حریم خصوصی.