رفتن به مطلب

خطا در مراحل اپگرید به 4.1


ارسال های توصیه شده

سلام در مرحله ی اخر اپگرید این خطا ظاهر شده علت چیه و چطور باید رفعش کنم ؟

 

Specified key was too long; max key length is 1000 bytes

 

home1/iair/public_html/forum/applications/core/sources/Setup/Upgrade.php::672

رفتم به مسیر گفته شده کد های زیر عامل خطا بود ولی نمی دونم چطور باید تصحیح بشن که خطا رفع شه

    /**
     * Step 2
     * Run a database check
     *
     * @return    array    Multiple-Redirector Data
     */
    protected function step2( $data )
    {
        return $this->appLoop( $data, function( $app ) use( $data )
        {
            $changesToMake = \IPS\Application::load( $app )->databaseCheck();
            if ( count( $changesToMake ) )
            {
                $toRun = \IPS\core\Setup\Upgrade::runManualQueries( $changesToMake );
                if ( count( $toRun ) )
                {
                    \IPS\core\Setup\Upgrade::adjustMultipleRedirect( array( 1 => $app, 'extra' => array( '_upgradeStep' => 2 ) ) );
                    return \IPS\Theme::i()->getTemplate( 'forms' )->queries( $toRun, \IPS\Http\Url::internal( 'controller=upgrade' )->setQueryString( array( 'key' => $_SESSION['uniqueKey'], 'mr_continue' => 1, 'mr' => \IPS\Request::i()->mr ) ) );
                }
            }
            return NULL;
        } );
    }

در کدهای بالا خطای نوشتاری اعلام کرده با این عنوان

syntax error , unexpect t_string ,
 expecting ' { '

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

با سلام

در 5 ساعت قبل، اکبری گفته است :

Specified key was too long; max key length is 1000 bytes

 

home1/iair/public_html/forum/applications/core/sources/Setup/Upgrade.php::672

پیام خطا همین یک تیکه بود یا چیزی هم ازش حذف کردید ؟

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در در 4 شهریور 1396 در 07:39، وحید نامنی گفته است :

با سلام

پیام خطا همین یک تیکه بود یا چیزی هم ازش حذف کردید ؟

 

همین بود

من از این ورژن برای ارتقا استفاده کردم IPS-Community-Suite-4.1.19.4-IPMafia-Nulled-فارسی

شاید اشکال از این ورژن باشه امکان داره از یک ورژن دیگه استفاده کنم خطا رفع شه ؟

 و اگر ابنطوره میشه راهنمایی بفرمایید چه ورژنی ازمایش شده است و پیشنهاد میدید ؟

93ia.png

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

متاسفانه همون طور که در تاپیک دیگه شما هم گفتم، مشکل از سرور شما هست که سازگار نیست.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...

اطلاعات مهم

ما مجبور شدیم تا از کوکی ها و فناوری های مشابه برای اجرای این وب سایت استفاده کنیم تا بتوانیم تجربه بهتری در زمان استفاده از سایت برای شما ایجاد نماییم. سیاست حریم خصوصی.