رفتن به مطلب

خطا هنگام نصب IPS در لوکال با XAMMP(حل شد)


ارسال های توصیه شده

سلام. xampp را روی کوبونتو نصب کردم. آپاچی و phpmyadmin بررسی کردم صحیح کار می‌کند. پوشه‌ی IPS هم در /opt/lampp/htdocs ساختم و فایل‌های IPS را به اونجا منتقل کردم اما وقتی آدرس localhost/IPS را میزنم با خطای زیر مواجه میشم. ممنون میشم راهنمایی کنید که دلیل این خطا چیست و چطور میتونم این مشکل را برطرف کنم؟

نقل قول

Fatal error: Uncaught Error: Class 'IPS\Dispatcher' not found in /opt/lampp/htdocs/IPS/init.php:501 Stack trace: #0 [internal function]: IPS\IPS::exceptionHandler(Object(Error)) #1 {main} thrown in /opt/lampp/htdocs/IPS/init.php on line 501

5953eec0ecd56_Screenshot__.thumb.png.1f24782a64276a9016c41990052e96fd.png

5953eef455337_Screenshot__.thumb.png.5e84916f798e006e22a7ca8f06b38a28.png5953eee3132bf_Screenshot__.thumb.png.95584a43c306a42d8d5b4ea948302f0a.png

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • پاسخ 26
  • ایجاد شد
  • آخرین پاسخ

سلام. ممنون بابت پاسخ. اما متأسفانه متوجه منظور شما نشدم. اگه منظور شما این است که IPS نصب بشه و بعد فراخوانی بشه که عرض کردم در ابتدای مرحله‌ی نصب طبق آموزش جناب نامنی باید آدرس localhost/IPS فراخوانی بشه. این آدرس نخستین اقدام برای شروع نصبه که متأسفانه در همین مرحله از من خطا می‌گیرد.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

IPS/opt/lampp/htdoc/

به گفته شما IPS  رو در این مسیر نصب کردید اگر اینطوره باید این آدرس فراخوانی بشه

localhost/lampp/opt/IPS

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

با سلام

XAMMP اصلا مناسب نیست چه برای ویندوز چه برای Linux !!

شما XAMMP رو پاک کنید با دستور زیر Lamp رو راه اندازی کنید :

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install lamp-server^

اون ^ یادتون نره.

در این پیرامون هم قبلا با یکی از دوستان بحث کردیم :

موفق باشید

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • وحید نامنی عنوان را به خطا هنگام نصب IPS در لوکال با XAMMP تغییر داد

سلام. ممنون بابت راهنمایی جناب نامنی.

من lamp را نصب کردم و در پوشه‌

/var/www/html/IPS

فایل‌های IPS را بارگذاری کردم. وقتی که در مرورگر آدرس مربوطه را وارد کردم با صفحه‌ی سفید بدون هیچ خطایی مواجه شدم.

فایل اسکریپت ملزمات IPS را بارگذاری کردم و ظاهراً دو خطا وجود داره. ممنون میشم راهنمایی کنید چطور این دو خطا را رفع کنم؟

You do not have the cURL PHP extension loaded or it is running a version less than 7.36. While this is not required, it is recommend to make calls to external API services faster. You may wish to contact your hosting provider or system administrator to ask for it to be installed.

You do not have the Zip PHP extension loaded. While this is not required, it is recommend. You may wish to contact your hosting provider or system administrator to ask for it to be installed.

البته لازم به ذکر است که این دو مورد سبز رنگ هستند، فقط تیک صحت را نخوردند و ورژن‌ها:

PHP Version 7.0.18-0ubuntu0.16.04.1

Server type: MySQL
Server version: 5.7.18-0ubuntu0.16.04.1 - (Ubuntu)

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

دستورات زیر رو وارد کنید :

sudo apt-get update
sudo apt-get install php7.0 php7.0-fpm php7.0-mysql php7.0-mbstring php7.0-common php7.0-gd php7.0-mcrypt php-gettext php7.0-curl php7.0-cli php7.0-xml php7.0-json php7.0-zip
sudo service apache2 restart

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

البته باید یادآور بشم از نسخه 16.04 به بالا دیگه برای نصب نیاز به دستور sudo apt-get install نیست و میبایست از دستور apt فقط استفاده کرد = sudo apt install

لینک ارسال
به اشتراک گذاری در سایت های دیگر

در 54 دقیقه قبل، وحید نامنی گفته است :

دستورات زیر رو وارد کنید :


sudo apt-get update
sudo apt-get install php7.0 php7.0-fpm php7.0-mysql php7.0-mbstring php7.0-common php7.0-gd php7.0-mcrypt php-gettext php7.0-curl php7.0-cli php7.0-xml php7.0-json php7.0-zip
sudo service apache2 restart

 

سلام. ممنون. الان همه‌ی تیک‌ها زده شده ولی همچنان من با صفحه‌ی سفید مواجه میشم که نه خطایی نشون میده و نه پیشرفتی. برای اطمینان وردپرس را دریافت و نصب کردم و مشکلی برای اجرا و نصب نداشتم. اما برای IPS همچنان با صفحه‌ی سفید مواجه میشم.

فکر کردم از فایل دانلودی است که مشکل ساز شده. بنابراین یکبار دیگه انجمن‌ساز را دریافت و دقیقاً بدون هیچ تغییری در html اکسترکت کردم ولی باز هم با همان صفحه‌ی سفید مواجه میشم. :hang1:

در 42 دقیقه قبل، j-akbari گفته است :

البته باید یادآور بشم از نسخه 16.04 به بالا دیگه برای نصب نیاز به دستور sudo apt-get install نیست و میبایست از دستور apt فقط استفاده کرد = sudo apt install

هر دو دستور جواب میده!!!!

لینک ارسال
به اشتراک گذاری در سایت های دیگر

عزیز میبایست فایل رو در پوشه مربوطه در مسیر var/www/html/posheh morede nazar اکسترکت کنید و اقدام به نصب کنید در ضمن وقتی وردپرس راحت نصب شده اینم باید نصب بشه

 

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...

اطلاعات مهم

ما مجبور شدیم تا از کوکی ها و فناوری های مشابه برای اجرای این وب سایت استفاده کنیم تا بتوانیم تجربه بهتری در زمان استفاده از سایت برای شما ایجاد نماییم. سیاست حریم خصوصی.