رفتن به مطلب

مشکل در نصب نسخه 4.0.7 و پیغام خطای 500


ارسال های توصیه شده

با سلام - طبق گفته مدیریت انجمن گفتند در یک تاپیک جداگانه موضوع را مطرح نمایم. 

می خواستم نسخه 4.0.7 را نصب کنم موقع نصب پیغام خطای زیر را می دهد:

An error occurred (500 Error)
We're sorry, but a temporary technical error has occurred which means we cannot display this site right now.

You can try again by clicking the button below, or try again later. 

فایل error_log هم به صورت زیر می باشد:

[10-Jun-2015 14:40:31 UTC] PHP Fatal error:  Class 'IPS\Dispatcher\Front' not found in /home/openfa/public_html/forums/index.php on line 13
[10-Jun-2015 14:40:31 UTC] PHP Fatal error:  Class 'IPS\Dispatcher\Front' not found in /home/openfa/public_html/forums/index.php on line 13

دستورات فایل htaccess موجود در این تاپیک رو هم در فایل htaccess قرار دادم ولی همچنان پیغام خطای بالا را می دهد.

آدرس سایت : انجمن اپن کارت فارسی - اپن فا

cPanel Version 	11.34.2 (build 8)
PHP version 	5.4.34
MySQL version 	5.1.68-cll
لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

با سلام :)

این فایل رو دریافت کنید و تست کنید آیا ببینید همه چیز برای شما سبزرنگ هست یا خیر.

http://ipsfarsi.com/files/file/1734-get-ready-for-IPS-40/

 

خطای درون errorlog نشون میده که یکی از فایل ها وجود نداره یا دارای مشکل هست. توصیه می کنم دوباره فایل ها رو آپلود کنید.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

با تشکر از پاسخگویی شما - فایل مورد نظر را دانلود کردم و در مسیر انجمن قرار داده و اجرا کردم تیک های همه زده شده بود به غیر از گزینه مربوط SQL

PHP Requirements

    PHP version 5.4.34.
    cURL extension loaded
    DOM extension loaded.
    GD extension loaded.
    Multibyte String extension loaded.
    MySQLi extension loaded.
    OpenSSL extension loaded.
    Session extension loaded.
    SimpleXML extension loaded.
    XML Parser extension loaded.
    XMLReader extension loaded.
    XMLWriter extension loaded.
    Zip extension loaded.
    128M memory limit.
    No Suhosin restrictions.

MySQL Requirements


    Warning: mysqli::mysqli(): (28000/1045): Access denied for user 'openfa'@'localhost' (using password: NO) in /home/openfa/public_html/forums1/ips4.php on line 294

    Warning: main(): Couldn't fetch mysqli in /home/openfa/public_html/forums1/ips4.php on line 297

    Warning: main(): Couldn't fetch mysqli in /home/openfa/public_html/forums1/ips4.php on line 299
    You are not running a compatible version of MySQL. You need MySQL 5.1.3 or above. You should contact your hosting provider or system administrator to ask for an upgrade.

    Warning: mysqli::query(): Couldn't fetch mysqli in /home/openfa/public_html/forums1/ips4.php on line 304

    Fatal error: Call to a member function fetch_assoc() on a non-object in /home/openfa/public_html/forums1/ips4.php on line 304

خطای داده شده ارتقای MYSQL را به نسخه 5.1.3 نشان می دهد...

این مطلب رو در ادامه قرار دادم تا اگر کاربران با مشکل بنده مواجه شدند بتوانند مشکل را رفع کنند...

 

راه حل = کاربرانی که این مشکل را دارند باید با هاست خود تماس بگیرند و نسخه MYSQL خود را ارتقا بدهند (به نسخه های بالاتر از نسخه 5.1.3  به بالا)

 

با تشکر از پاسخگویی شما ....

لینک ارسال
به اشتراک گذاری در سایت های دیگر

با ارتقای نسخه MySQL  به نسخه بالاتر باز مشکل حل نشد.

وقتی فایل تست نسخه 4 رو در مسیر روت سایت اجرا می کنم به صورت زیر نمایش داده میشه:


IPS Community Suite 4.0
phpinfo
PHP Requirements

    PHP version 5.4.42.
    cURL extension loaded
    DOM extension loaded.
    GD extension loaded.
    Multibyte String extension loaded.
    MySQLi extension loaded.
    OpenSSL extension loaded.
    Session extension loaded.
    SimpleXML extension loaded.
    XML Parser extension loaded.
    XMLReader extension loaded.
    XMLWriter extension loaded.
    Zip extension loaded.
    128M memory limit.
    No Suhosin restrictions.

MySQL Requirements

    MySQL connection could not be established to perform version check. Make sure your MySQL Server version is 5.0.3 or above (5.6.0 or above recommended).

Additional Requirements

Summary

You are ready to install IPS Community Suite 4.0!

To check if you can upgrade an existing installation of IP.Board 3.x, upload this script to the directory where your community is installed.

و طبق نمایش صفحه بالا میگه که اطلاعات خوب هستش و شما می توانید نسخه 4 را نصب کنید...

 

حال اگر همین فایل تست رو در مسیر پوشه (ساب دومین) قرار بدهید پیغام خطایی که در تاپیک 3 گذاشته ام نمایش می دهد و ارتقای نسخه MYSQL را می خواهد در حالی که نسخه MySQL نسخه جدید می باشد...

و همچنین در روت و ساب دومین که می خواهی مراحل نصب رو انجام بدهی در همان ابتدای کار پیغام خطای زیر نمایش داده میشه:


An error occurred (500 Error)
We're sorry, but a temporary technical error has occurred which means we cannot display this site right now.

You can try again by clicking the button below, or try again later.


و اصلا وارد مراحل نصب نمیشه .....؟؟؟؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

اگر در روت سایت تون مشکلی نداره ولی در ساب دومین ها چنین مشکلی هست، صد در صد از تنظیمات سرور هست که باید با پشتیبانی سرور مشکل رو درمیون بگذارید.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...

اطلاعات مهم

ما مجبور شدیم تا از کوکی ها و فناوری های مشابه برای اجرای این وب سایت استفاده کنیم تا بتوانیم تجربه بهتری در زمان استفاده از سایت برای شما ایجاد نماییم. سیاست حریم خصوصی.