رفتن به مطلب

خطا در تنظیم وب کانفیگ برای سرور های ویندوز:


ارسال های توصیه شده

بنده این نسخه جدید رو نصب کردم ازمایشی و خوب چون قصد دارم در اینده نزدیک از این نسخه  IPB  استفاده کنم در حال بررسی ان می باشم و نکته اصلی مشکل روی تنظیمات فایل web config  روی سرور های ویندوزی است که وقتی Rewrite URLs را فعال می کنیم لینک های سایت نمایش داده نمی شود و خطا دسترسی می دهدکه بنده ان را مرتفع کردم ولی مشکل حالا روی یونیکدهاست یعنی وقتی پستی ارسال میشه با جملات فارسی ان صفحه باز نمی شود و خطا می دهد

ایا برای رفع این مشکل راهکاری وجود دارد یا اصلا کانفیگ خاصی وجود دارد ممنون میشم راهنمایی بفرمایید

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi

با سلام :)

این نکته رو باید دقت داشت که اصلا ویندوز محیط مناسبی برای اجرای PHP نیست. در مورد مشکل انکودینگ لطف اآدرس انجمن تون رو بدید تا از نزدیک بشه بررسی کرد.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

مرسی از اینکه پیگیر بودید

خوب درسته تا حدی حق باشماست ولی خوب مزیت های خاص خودش هم داره و تا بحال مشکل اساسی نداشتیم در این مورد و این به واقع تصور می کنم مشکلی باشه که قابل رفع هست ولی خوب در سطح تخصص من نیست ادرس رو براتون پیوست می کنم و دو پست هم ارسال کردم

پستی که با عنوان انگلیسی هست لودینگ داره ولی پستی که لودینگ نداره برای عنوان فارسی هست من کانفیگی که کردم رو براتون کد می کنم تا شما هم بررسی نمایید بازهم ممنون از شما

http://www.lonanet.com/

و این هم کانفیگی هست  که انجام دادم 

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
	<system.webServer>
    	<rewrite>
        	<rules>
            	<remove name="Imported Rule 1" />
            	<remove name="Imported Rule 1-1" />
            	<rule name="Imported Rule 1" stopProcessing="true">
                	<match url="." ignoreCase="false" />
                	<conditions logicalGrouping="MatchAll">
                    	<add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
                    	<add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
                	</conditions>
                	<action type="Rewrite" url="/beta/index.php" />
            	</rule>
        	</rules>
    	</rewrite>
	</system.webServer>
</configuration>

امیدوارم دوستان بتوانند کمک من در این مسله باشند چون این اخرین مشکل فکر کنم باشه که حال وجود داره در مورد استفاده این اسکریپت که به نظرم بهترین هست در نوع و جایگاه خودش ....منتظر نظرات شما دوستان هستم

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • مدیر کل بازنشسته سایت

چون وب سرورتون iis هست داستان خاص خودشو داره همراه با کلی دنگ و فنگ.

 

این تاپیک رو بخونید توضیحات لازمه داده شده:

http://community.invisionpower.com/topic/408434-url-friendly-for-windows-server-htaccess-file/

 

 

تو پست دومی که گفته کد htaccess که باید تبدیل بشه اینه: طبق این اموزش:

https://help.webcontrolcenter.com/kb/a1487/iis7-url-rewrite-importing-iis-mod-rewrite-rules-apache.aspx

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(jpeg|jpg|gif|png)$ /public/404.php [NC,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
لینک ارسال
به اشتراک گذاری در سایت های دیگر

بله دنگ و فنگ خودش رو داره و البته من تمام این مراحل رو با کمی تغییرات رفتم قبلا  و همانطور که عرض کردم لینک ها درست کار می کنه جز عنوان های که با فارسی اغاز می شوند و موقع تبدیل کد هم خطا روی این کد وجود داره

RewriteBase /

ایا راهی برای جایگزین کردن این کد می تونه وجود داشته باشه و یا نه بخاطر تازگی نسخه این می تونه یک باگ باشه که مرتفع میشه ...؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

  • بنیان گذار IPSFarsi
ایا راهی برای جایگزین کردن این کد می تونه وجود داشته باشه و یا نه بخاطر تازگی نسخه این می تونه یک باگ باشه که مرتفع میشه ...؟

این هست :

http://stackoverflow.com/questions/26219999/how-to-rewrite-base-path-i-e-with-iis-rewrite

 

در مورد انکودینگ متاسفانه من نمی تونم کمکی بکنم چون تخصصی توی IIS ندارم ولی مطمئنا از وب سرور شما هست که درست نمی تونه همه چیز رو هندل کنه. این رو اگر توی انجمن های هاستینگ مطرح کنید مطمئنا به پاسخ می رسید.

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بله انگار مشکل از iis هست و در سایر اسکریپت ها هم این مشکل وجود دارد هرچند انگار راهی برای رفع این مشکل در ورد پرس و لینک های یکتا ان پیدا کردند ولی برای این اسکریپت فعلا جستجوهای من بی نتیجه بوده ..باز هم مرسی از پیگیری که داشتید

لینک ارسال
به اشتراک گذاری در سایت های دیگر

بایگانی شده

این موضوع بایگانی و قفل شده و دیگر امکان ارسال پاسخ نیست.

  • کاربران آنلاین در این صفحه   0 کاربر

    • هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.
×
×
  • اضافه کردن...

اطلاعات مهم

ما مجبور شدیم تا از کوکی ها و فناوری های مشابه برای اجرای این وب سایت استفاده کنیم تا بتوانیم تجربه بهتری در زمان استفاده از سایت برای شما ایجاد نماییم. سیاست حریم خصوصی.